Tech Preview

SLE BCI PHP 8

PHP 8 based on the SLE Base Container Image.

Get Image
Digest:
sha256:164e91d0d4e20b1a57c83dec0716b80b38511cb3f43b761b089d2a351b15c72d
164e91d0d
Repository:
registry.suse.com/bci/php:8

Description

The PHP 8 container image

Redistributable SLSA Provenance: Available

PHP is a general-purpose scripting language used primarily for server-side web development. It can be used directly, embedded in HTML files, or executed via a server-side Apache2 module or CGI scripts.

How to use the image

This image ships with the PHP interpreter as the entrypoint. The image is intended to be used to execute PHP scripts or PHP commands directly.

To launch an interactive shell in a container, use the following command:

$ podman run --rm -it registry.suse.com/bci/php:8
Interactive mode enabled

php > echo 5+8;
13

You can also use the container instead of the PHP interpreter to execute PHP scripts:

$ cat /tmp/test.php
<?php
echo 5+8
$ podman run --rm -it -v /tmp/test.php:/src/test.php:Z \
    registry.suse.com/bci/php:8 -f /src/test.php
13

How to install PHP extensions

PHP extensions must be installed using the zypper package manager. PHP extensions are named using the php8-$extension_name scheme, and they can be installed as follows:

FROM registry.suse.com/bci/php:8

RUN zypper -n in php8-gd php8-intl

Alternatively, you can use the docker-php-ext-install script. It is provided for compatibility with the PHP DockerHub Image but it uses zypper to install the extensions from RPMs. It is provided for compatibility reasons and can be used similar to the script from PHP DockerHub image:

FROM registry.suse.com/bci/php:8

RUN docker-php-ext-install gd intl

How to install PECL extensions

PECL is a package repository hosting PHP extensions. It can be used as an alternative source to obtain PHP extensions, but without any guarantee of interoperability with this image and without any official support.

PECL extensions can be installed as follows:

FROM registry.suse.com/bci/php:8

RUN set -euo pipefail; \
    zypper -n in $PHPIZE_DEPS php8-pecl; \
    pecl install APCu-5.1.21;

Note: Building an extension may require installing additional dependencies.

Compatibility with the DockerHub Image

The following scripts ship with the image to keep it compatible with the DockerHub image: docker-php-source, docker-php-ext-configure, docker-php-ext-enable, and docker-php-ext-install. Note that only docker-php-ext-install performs an actual job. None of the other scripts require to be executed in the image.

Licensing

SPDX-License-Identifier: MIT

This documentation and the build recipe are licensed as MIT. The container itself contains various software components under various open source licenses listed in the associated Software Bill of Materials (SBOM).

This image is based on SLE BCI, a stable and redistributable foundation for software innovation. SLE BCI is enterprise-ready, and it comes with an option for support.

See the SLE BCI EULA for further information.

  • Image Data

    Last Built: 19 Jun 16:49 UTC

    Size: 53.2 MB

    Support Level: Techpreview


  • Health Index
    D
    0:C52:H48:M8:L13:U

    Last Scan:

    about 14 hours ago